Lawnmower issues

Discussion in 'Community Forum' started by predator1, Apr 15, 2015.

  1. predator1

    predator1 12 pointer

    Dec 25, 2008
    Any lawnmower guru's out there?. It's a craftsman with a 22hp Kohler engine. I can't seem to find the issue. It has to be electrical. It was running and mowing, then the mowing deck shut off and then the engine. It won't even turn over now. Nothing, zip, zilch, nada. I can short the solenoid and it will turn over, but won't fire. I've checked the switch under the seat, but it didn't change anything. It has done this before, but it would start right up about an hour later and wouldn't mess up again for months at a time. For whatever reason, it struck again today. I'd really like to resolve this issue.
  2. KYBH4Life

    KYBH4Life Banned

    Feb 13, 2011
    Would double-check that switch under seat. Does it backfire at all? If switch is jumpered, wire to connector could be loose
  3. slobear

    slobear 12 pointer

    Nov 20, 2014
    Trump town, USA
    Check around the solenoid for a 20 amp fuse. Any fuse for that matter.
  4. JDMiller

    JDMiller 12 pointer

    Jun 12, 2005
    " Between the Rivers "
    Definitely no small engine mechanic but I've owned two craftsman riders over the years and had a variety of issues. Which as mentioned I'd check the safeties but don't overlook simple things as the battery or fuses.

    On one of the craftsmen I had it just died on me similar to what you described and I was about to pull my hair out. Got checking things and found a 15 amp fuse (blade type automotive style) that the filament was broke. Had no indication of it being blown just appeared maybe vibration got it.

    Also on the cub I have at present which I had bought new and had it about 5 years ... I was mowing along and it just quit. I'm checking things but happened to notice the digital hour meter wasn't displayed. Checked battery voltage and it was extremely low and wouldn't charge. Basically like a dead cell .. so I put a new battery on it and all was good. But just like most vehicles these days it gave me no warning other than me knowing the joker was 5 years old and was time for it to be replaced. However at the time the mower had been starting fine not sluggish at all.

    Ultimately there's a lot of electronic crap on mowers that we don't think about.

    Which I'm taking it that when you turn the key it's not doing anything at all. As such if your starter is turning over ... I'd check to make sure your getting fire to the plug and start from there. Which I've had real good service from Kohler engines over the years it's probably something relatively simple if you can narrow down where the problem is.

    Good luck.

    Sent from my iPhone using Tapatalk
  5. predator1

    predator1 12 pointer

    Dec 25, 2008
    Battery is definitely good. I can short the solenoid and the the engine will turn over fine, it just makes zero attempt to fire. It doesn't backfire because I'm getting no spark. It won't even turn over with the key?! I think it has to be in the electrical/safety circuit killing everything
  6. davers

    davers 12 pointer

    Jul 14, 2014
    The above suggestions dealing with your mower problem might be correct. However does the gas cap have an air hole? An air hole is needed inorder to feed gasoline to the engine Might check the gas cap to see if it has a large enough hole. ~Just my guess!
  7. Davidlondon4

    Davidlondon4 12 pointer

    Dec 2, 2004
    Laurel County
    I don't think what I am about to tell you is the problem but will post this just for informational purposes.I have a Sears Craftsman with a Kohler engine. Motor is 17.5 HP and its over10 years old. My mower took a spell of shearing pins in the engine and I replaced several of them till I figured out what was going on.Come to find out my carburetor was messed up and after mowing gasoline continued to leak into the engine compartment when it was parked in the garage. So much gas that the engine wouldn't turn over. I started removing the plug to release the pressure on the engine and crank it to dry it out. Engine would start and work fine when the plug was reinstalled. Let it set till the next mowing same thing --- engine wouldn't turn over. I was going to take it to a repair man but he said it would be 3 or 4 weeks before he could get to it. I ended up putting a shut off valve in the gas line between the tank and the carburetor and always shut off the gas supply when I am through mowing. This solved my problem and I have been using the mower like this for the last couple of years.
    davers air hole suggestion could also be the culprit.
  8. inchr48

    inchr48 10 pointer

    May 14, 2013
    NW Indiana
    Also check to see if you have a safety switch on the blade engagement lever. I've had that wire break before and it will kill your ignition.
  9. huntr467

    huntr467 12 pointer

    I am assuming this is an older type Craftsman? I can tell you your seat switch is not the problem. Just fyi the seat switch does not prevent the mower from starting (Turning over) it does prevent spark in certain instances. 4 things that are included in the starting circuit, clutch/ brake pedal, PTO switch, ignition switch and solenoid. Crossing a solenoid does not mean the solenoid is good.

    Now to the problem. The way you explained it with the pto stopping first and then the engine, It poinst to maybe a pto switch or a bad ground.
    Here is what I would try....turn your key to the on position, lock your brake down, make sure pto switch is off, cross solenoid and see if engine will fire. You do not have to be on the seat as long as the brake is locked.

    Craftsman are also bad about loosing ground. check your ground cable where it goes to the frame.

    If you have a test light the next step would be to test the starting circuit. Same as above brake locked, pto off, check to verify engine is grounded, turn key to start position and see if one of the small wires on the solenoid are hot, if not go to the back of the key switch and find the one that lights up when you turn the switch to the start position. If none light up then we need to verify the ground is making it to the switch. there will be a black wire that should be going to the grounding circuit. If the switch is grounded and nothing is coming out in the start position then the ignition switch is bad.
    If we have a hot wire when the key is turned to the start position (sometimes orange Note: there are going to be several hot wires on the back of the switch, we want the one that only gets hot when you turn the key to the start position) then go to the switch on the brake pedal and verify that wire of the same color you found on the key switch is hot in and out when key is turned to start position. ( that switch will have 4 wires). If it is coming in and going out when you turn the key to the start position I would venture to guess you have a bad pto switch. Which I would have probably tried first before going through all that but they will cost you about $30 and non refundable electrical parts get expensive to just be parts swapping.
    If all else fails take it to a shop ;) or shoot me a pm I can help more maybe.
  10. Wildcat

    Wildcat 12 pointer

    Jan 7, 2002
    Ledbetter, Ky.
    This has happened to me before.
  11. EdLongshanks

    EdLongshanks 12 pointer

    Nov 16, 2013
    Northern Kentucky
    The nut that holds the ground wire to the frame loosened on my mower. It started running rough and the motor was incrementally cutting out. Rolling over rough spots in the yard made the problem worse. I was ready to load it up and take it back (it was less than a year old) but luckily my wise old man clued me in on the problem.

    It seems like your problem is more related to a safety switch or relay...I guess
  12. quackrstackr

    quackrstackr Welcome to Fantasy Island Staff Member

    Nov 19, 2003
    The Island
    Depending on the age of the mower and the type of engagement... I suspect this is probably the issue.
  13. littlebear

    littlebear 12 pointer

    Aug 21, 2007
    the woods
    1. Safety on seat
    2. Deck engage switch
    3. Fuse blown
    4. Solenoid
  14. predator1

    predator1 12 pointer

    Dec 25, 2008
    Is there a way to bypass the pto switch to see if it will start?
  15. slobear

    slobear 12 pointer

    Nov 20, 2014
    Trump town, USA
    Not trying to be a smart*** but have you checked for a blown fuse? You may have to remove tank, google make and model for diagrams, but it sounds to me like a 20 cent fuse could fix your trouble. Of course you can bypass any switch, normally closed- tie straight together, normally open not your problem. Likely a single blade type fuse around solenoid.

Share This Page