ATV Question

Discussion in 'General Hunting' started by xbokilla, Oct 5, 2018.

  1. xbokilla

    xbokilla 12 pointer

    7,178
    1,486
    Jun 28, 2012
    Guess I’ll put this in general hunting since that’s what I use it for. I rolled my ATV on its side about 3 weeks ago. No biggie. Some oil leaked out, not much at all. I checked it cold and all of my fluids look good. However, on Wednesday road it on a property we got access to and about the time I got it back to my trailer it said Engine Hot. I’m not a guru and don’t feel like giving up the big bucks to have it checked. I basically paid an arm and leg and had it overhauled in Fall of 15 so can’t be much wrong with it. Any idea what I should check? Would simple burn off on the engine cause this? I did run it in AWD Hi/Lo more than I usually do. It was pretty muddy.
     
  2. muddhunter

    muddhunter 12 pointer

    3,178
    328
    Oct 18, 2005
    louisville
    If it was super muddy you might try washing it. make sure the fins aren't clogged so they can cool properly.
     
    ojibwa62 likes this.
  3. ojibwa62

    ojibwa62 12 pointer

    2,867
    1,248
    Jul 1, 2018
    Waco
    Check the radiator if it had one. I have seen them clog with mud and plant Duff, if it has an electric fan make sure it's working.
     
    carnivore likes this.
  4. xbokilla

    xbokilla 12 pointer

    7,178
    1,486
    Jun 28, 2012
    It’s 2007 Polaris 500 EHI if that helps. Pretty much all electric. I’m just not the best. I’ve changed the battery and checked fluids. That’s about the extent of my grease monkey work. I just know without it my 76 year old pops won’t get to hunt with me much so I’m trying to be proactive.
     
    ojibwa62 likes this.
  5. ojibwa62

    ojibwa62 12 pointer

    2,867
    1,248
    Jul 1, 2018
    Waco
    Pretty sure it has a rad and a fan ? Maybe .... It might ... Heck I don't know.. if it has a rad get on the back side of it and blast some water through the fins also as it sits there and idles see if the fan comes on, check all the connections.. it might also have relay if you can't find it check on YouTube or Google it..
     
  6. carnivore

    carnivore 12 pointer

    3,792
    1,334
    Nov 17, 2007
    California ky
    Start with the radiator.
     
    ojibwa62 likes this.
  7. Dark Cloud

    Dark Cloud 10 pointer

    1,882
    964
    Aug 14, 2009
    Lawrence Co.
    Could be a loose wire ,from when you turned it over.Recheck oil make sure it’s where it’s suppose to be.Might have pinched a wire or broke a wire going to your fan.
     
  8. 1wildcatfan

    1wildcatfan 12 pointer

    5,816
    748
    Jan 2, 2009
    raised n Bullitt Co.
    shoulda bought a Honda. :) i rolled mine and it kept running fine.

    i'd spray all the mud off, check the radiator, the fan. My honda has an fan that kicks on every so often. maybe something as simple as a loose connection.
     
    Ataulbe1, bigbonner and OLE RASPY like this.
  9. rcb216

    rcb216 12 pointer

    3,039
    238
    Sep 25, 2005
    Robertson Co.
    All the above posts is sound advice. I can’t add anymore to it. If it’s above your ability get a friend offer him a 12 pack or $ for checking it out.
     
    bearleft likes this.
  10. jim rifanburg

    jim rifanburg 6 pointer

    178
    155
    Jul 27, 2016
    If it is hot you should here fan running even after you shut engine off if not then it’s the fan
     
    barney likes this.
  11. barney

    barney 12 pointer

    7,846
    3,208
    Oct 11, 2005
  12. OLE RASPY

    OLE RASPY 6 pointer

    256
    109
    Sep 9, 2018
    Glasgow Ky
  13. WildmanWilson

    WildmanWilson 12 pointer

    9,246
    1,116
    Dec 26, 2004
    Western Ky.
    I had a dirt dobber nest on my fan and it got hot because it stopped it from turning. Doesn’t take much at all to stop it.
     
  14. xbokilla

    xbokilla 12 pointer

    7,178
    1,486
    Jun 28, 2012
    In 2011 I flipped it head over end going, right across my face, as I ascended up a mountain. All it did was chipped the plastic Polaris emblem on the front. If it quit tomorrow, I’ve got my $ worth. It’s been a beast.
     
  15. xbokilla

    xbokilla 12 pointer

    7,178
    1,486
    Jun 28, 2012
    Thanks for the advice. I’ll check the radiator, top fluids, and spray it off real good. I have driven it several times since I turned it on it’s side and leaked oil. It wasn’t until I was about to load it and turned it back on that I saw the Engine Hot come on. I had driven it pretty hard and over, through some tough terrain up to that point. The weird thing is that it didn’t feel hot. If you drive it a lot in AWD hi/lo it will actually feel a little hot (although the message has never appeared) that’s what makes me feel like it’s fluids or run off somewhere.
     

Share This Page